The Dawn Of Time
The Official Forums for the Dawn Of Time Mud Codebase
 
Log in Register FAQ Memberlist Search The Dawn Of Time Forum Index Goto the Official Dawn Website

not a bug and an unrelated potential typo

 
Post new topic   Reply to topic    The Dawn Of Time Forum Index » 1.69r typos and mobprog bug reports
View previous topic :: View next topic  
Author Message
Slayer



Joined: 27 Jun 2004
Posts: 33
Location: New Zealand

PostPosted: Tue Jul 06, 2004 6:26 am    Post subject: not a bug and an unrelated potential typo Reply with quote

Nowhere to really post this but perhaps it's just my platform but when my imp types

spsklist

this happened;

----->
This needs to be commented out in interp.cpp;

// { "spsklist", do_spellskilllist, POS_DEAD, IM, LOG_ALWAYS, 1 },

otherwise watch your gamelog increase to 350+ k in a few seconds
with no sign of stopping;

:: [*****] BUG: category_indexlookup(): Invalid index 24!
[...]
:: [*****] BUG: category_indexlookup(): Invalid index 5565!
<-----

I had to crtl-c the dawn process and bring down the mud. Sokay for me since I was the only one logged in but not so good if you're running a production mud.

The reason I said maybe it's just my platform is because I can't believe noone else has reported it.

also; since we are in typo section but regarding r revision tonight wifey was saying when she types exits say 2 or so east from Mekali in the path description it says leading to and from Midgaard

here we are:

Exit east 30219
EDesc A trail leading eastward from Midgaard.

Exit east 30220
EDesc A trail leading eastward from Midgaard.

Exit west 30218
EDesc You see the trail back to Midgaard.

Exit west 30220
EDesc You see the trail back to Midgaard.

I did suggest to her it was just one of those in jokes or personal touches.

yes, wifey likes the full exits displayed each movement, and I've lost track of how many codebases I've altered for this reason. Any plans to provide this in a triple autoexit toggle?



_________________
~Yes I am a Kiwi, No, I did not appear as an extra in 'Lord of the Rings'~
Back to top
View user's profile Send private message
Archiel
Moderator


Joined: 05 Feb 2003
Posts: 386
Location: Minnesota, USA

PostPosted: Tue Jul 06, 2004 11:33 am    Post subject: Reply with quote

I had the same problem on my system. I run OS X, a FreeBSD derivative.
I did mention a similar problem http://forum.dawnoftime.org/viewtopic.php?t=968. I honestly can't remember how closely related this one was....

I did see the same error however. I think I fixed it with some ugly hack, but I can't remember what I did. I'll check into that tonight, if I have a chance. Anyway, when it hit 10000 or something it stopped...

What exactly is your platform? Also, could you check to see if you get the same error I got on stock dawn, as I posted on the above topic?

Thanks a lot!



_________________
-Archiel
Back to top
View user's profile Send private message Send e-mail Visit poster's website AIM Address
Slayer



Joined: 27 Jun 2004
Posts: 33
Location: New Zealand

PostPosted: Tue Jul 06, 2004 5:23 pm    Post subject: Reply with quote

My understanding of it (since there is only one instance of spsklist in the entire source code collective) is it's a redundant command and was meant to be // out with some other examples contained within already // and just got overlooked for this release.

I had a quick glance at your reference thread and can't say I've experienced anything similair. But I have yet to modify anything from stock Dawn_R so I'll revisit this if I step into your shoes, I will go back to your thread and focus on what you were doing and try and duplicate it as you ask.

I'm running AmigaOS3.9 BB2 and generating code with 3.4 g++.

also in conf.h; if applicable.

/* Define if you have zlib.h. */
/* #undef HAVE_ZLIB */
[choose not to have this (have a very basic gg tree installation and only install other packages on a need/trial basis, I keep well away from any form of compression)]

/* #define IPV6_SUPPORT_ENABLED */
[not sure if I have a choice here but after configuration it's commented out prior to make]



_________________
~Yes I am a Kiwi, No, I did not appear as an extra in 'Lord of the Rings'~
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    The Dawn Of Time Forum Index » 1.69r typos and mobprog bug reports All times are GMT + 13 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001-2005 phpBB Group
Theme created by Vjacheslav Trushkin