The Dawn Of Time
The Official Forums for the Dawn Of Time Mud Codebase
 
Log in Register FAQ Memberlist Search The Dawn Of Time Forum Index Goto the Official Dawn Website

Getting disconnected upon trying to enter my name to log in!

 
Post new topic   Reply to topic    The Dawn Of Time Forum Index » Getting Started
View previous topic :: View next topic  
Author Message
miruim



Joined: 15 Apr 2009
Posts: 1

PostPosted: Wed Apr 15, 2009 11:08 am    Post subject: Getting disconnected upon trying to enter my name to log in! Reply with quote

Hi there,

I've downloaded the source code base, created a new project on Microsoft Visual Studio 2008, imported all the files (including system support files) and built it. I ran the executable. Everything went OK.

I can connect to it (127.0.0.1, on default port 4000), but when I try to enter any name, I get automatically disconnected. If I type ENTER without typing anything, it tells me to either type new, quit or enter my name, as usual, but if I type anything, I get disconnected.

What's going on?
Problem with the socket or client handling code? (I don't believe so.)
How to make it work?

I'm a complete newbie to coding at all.

Thanks


Back to top
View user's profile Send private message
Kalahn
Codebase Developer


Joined: 18 Jan 2003
Posts: 710
Location: New Zealand

PostPosted: Fri Apr 17, 2009 3:41 pm    Post subject: Reply with quote

What mud client are you using?
Is it set to autoconnect and connecting using an old character password?

- Kal


Back to top
View user's profile Send private message Visit poster's website
Daos



Joined: 29 Jan 2003
Posts: 1219
Location: United States

PostPosted: Sat Apr 18, 2009 3:42 pm    Post subject: Reply with quote

Hi -

Which source did you download? If you downloaded 1.69s_beta4; one situation it could be involves the DAWN_STATIC_BETA_RELEASE_EXPIRY_DATE which will disallow anyone that is a non-immortal from connecting to the game after the defined date expires (which was a long time ago) - so naturally you wouldn't be able to connect.

One solution to that would be to create a player file using a 1.69r binary; edit the player file level so its 100 manually using word, notepad, or any other text file editor, then copy the player file over to the current running mud player directory.

Mind you, this is only IF you are trying to boot using the 1.69s_beta4 code.



_________________
- Daos

http://www.dawnoftime.org
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    The Dawn Of Time Forum Index » Getting Started All times are GMT + 13 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001-2005 phpBB Group
Theme created by Vjacheslav Trushkin