The Dawn Of Time
The Official Forums for the Dawn Of Time Mud Codebase
 
Log in Register FAQ Memberlist Search The Dawn Of Time Forum Index Goto the Official Dawn Website

Complete Nublet

 
Post new topic   Reply to topic    The Dawn Of Time Forum Index » Getting Started
View previous topic :: View next topic  
Author Message
rixthia



Joined: 24 Oct 2014
Posts: 6

PostPosted: Fri Oct 24, 2014 8:48 am    Post subject: Complete Nublet Reply with quote

I have another post elsewhere about other stuff, but now I'm coming to the start for the bare bones as well. Here's the lowdown:

Music Teacher creating a MUD with Dawn code for the abilities to add our own sound/music through MSP and work on our literacy skills in reading/writing.

The information pertaining to where I'm being hosted.

Processor: AMD Opteron 2360 SE 2.5 GHz (Single Virtual Core)
Memory: 1GB DDR2 PC2-5300 667Mhz ECC Registered
Hard Drive: 160GB Virtual Disk on RAID5 array
Connection: 40MB/20MB Cable Network w/ Static IP
Network: Quad Gigabit Ethernet in bond0, Redundant Network Switching
Operating System: Debian 4.0 Lenny 32-bit
Linux Kernel: 2.6.18-6-486
Software: Apache 2.2.3, PHP5.2, MySQL 5.0.32, Lua 5.0.3, GCC and G++ 2.95, 3.3, 3.4 and 4.1, Valgrind 3.2.1
Environment Details: 24/7 Monitoring, UPS Battery Backup, Generator Backup, 99% Network Uptime, Professionaly Located Server

Issues:

1) I'm allowed one port. I ran ./dawn 1300 so I have port 1300 in use. Then I messed it up (see issue 2), tried a fresh install, nothing changed, and now I typed ./dawn which has it running on port 4000. How do I close those ports? (I don't even know how to read what I'm looking at when I tried ps and such to figure out which processes to kill...)

2) I used hotreboot to try and implement some changes. When I did, my pfile messed up. I went into the .plr and changed the pword back to what it was (the hotreboot changed my pword). My pword was still not accepted. So I deleted my .plr and went to create a new character. My race works fine, but now there's no classes being recognized. I went into class.txt and changed mage to creation true and human 1000 for base xp. It is still missing though from classinfo when it goes to classselect.


3) How does one recompile? I've tried hotreboot and made issue 2. I tried deleting configure, makefile, dawn... and then doing ./configure, make, ./dawn again and that didn't change anything either.


Help?

...

Thank you.


Back to top
View user's profile Send private message
derek



Joined: 23 Sep 2007
Posts: 125

PostPosted: Sat Oct 25, 2014 10:13 pm    Post subject: Reply with quote

For issue 1, you need to change the port_default setting either by editing gameset.txt while the mud is shut down or doing it within the mud via the gameedit. The steps for that would be 'gameedit confirm', 'value port_default 1300', 'done', 'savegameset'. If you do it from within the mud, you'll need to shut it down and restart to get it running on the correct port. (There are alot of things which are editable within gameedit. It's worth looking through carefully, and is generally going to be preferable to editing the gameset.txt file by hand. In this instance, I'd just shut the game down and do it by hand but either method will get the job done.)

For issue 3, you only need to run configure if some aspect of your installation has changed. If you are only editing the .cpp files, then you can get away with simply doing 'make' and then hotrebooting in game. If you change any of the .h header files, then you need to 'make clean', 'make' and then hotreboot.

Issue 2 is difficult to guess at. I can't think of any particular reason why your password would be affected by a hotreboot. Passwords are hashed in pfiles, so it might look like gibberish, but I've never experienced or heard of passwords getting mangled in pfiles in this codebase. You should probably be doing all the editing of classes possible with the classedit command, for whatever that's worth.


As for the the output of ps:

Code:

$ ps aux | grep dawn
delwin   13724  0.0  1.9  28572  9860 ?        Ss   04:48   0:00 ./dawn


13724, the first number after the name of the user running the process, is the PID.


Back to top
View user's profile Send private message
rixthia



Joined: 24 Oct 2014
Posts: 6

PostPosted: Sun Oct 26, 2014 1:38 am    Post subject: Reply with quote

Thank you Derek. That worked for issue 2 and 3. I have not yet tested issue 1. I love how all the linux/unix sites I've found through Google so far show people the command and what it looks like, but never explains the output tables. Laughing


Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    The Dawn Of Time Forum Index » Getting Started All times are GMT + 13 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001-2005 phpBB Group
Theme created by Vjacheslav Trushkin